AutoCAD information re: Construct

  • May 7, 2019 at 3:44 pm #236496
    Diane Burgess
    Participant

    AutoCAD 2020 was released at the end of March 2019. Per Autodesk T&C’s they support the current version and three back. Therefore, AutoCAD 2016 is now an unsupported version.

    We encourage our customers who are using Construct 12 or below to consider upgrading to Construct 13 with a supported AutoCAD version.

    • Construct 12 currently requires AutoCAD 2016
    • Construct 13 currently requires AutoCAD 2018
    • Construct 14 (will release mid-year 2020) will require AutoCAD 2020

    If you are currently using AutoCAD 2016 on prem there are no issues (besides support) in continuing to use this version. If you are a subscription customer, you can continue to renew with AutoCAD 2016 as well. You will not be able to add additional licenses of an unsupported version or renew an unsupported version if the subscription lapses.

     

You must be logged in to reply to this topic.

Topic Tags

Share this Post